This issue has now been resolved. The email service is back to expected levels, with POP/IMAP and Webmail functioning as intended. We apologise for the inconvenience caused.
Posted Nov 18, 2024 - 20:36 GMT
Monitoring
POP/IMAP connections are currently returning to expected levels for both mail clients and Webmail access, but are still intermittently slower than expected response times. Our mail provider is continuing to work on this and monitor the results, and we will post updates as they are available. We apologise again for any inconvenience this is causing, and appreciate your patience.
Posted Nov 18, 2024 - 16:18 GMT
Investigating
We have received reports of some users having issues accessing webmail, as well as sending and receiving mail. We are investigating this. Apologies for any inconvenience that this may cause.
Posted Nov 18, 2024 - 12:11 GMT
This incident affected: General Services (EKM Mail).