Server 39 Loading Issues

Incident Report for EKM

Resolved

This incident has now been resolved.
Posted Mar 19, 2025 - 17:22 GMT

Investigating

There's a technical issue affecting page loading at the moment. Our Engineering Team are currently investigating. If this issue is affecting your EKM online shop, you can subscribe to updates here and this will ensure you'll receive an update when a resolution has been rolled out. Sorry for the inconvenience this may cause and thank you for your patience
Posted Mar 19, 2025 - 16:55 GMT
This incident affected: Shop Servers (Shop Server 39).