Issue Accessing Some Mailboxes
Incident Report for EKM
Resolved
This issue has now been resolved .We appreciate your patience and apologise for any inconvenience caused.
Posted Nov 14, 2024 - 11:07 GMT
Update
We are continuing to investigate this issue.
Posted Nov 14, 2024 - 08:34 GMT
Investigating
Our mail provider has advised that access to some mailboxes is restricted whilst under maintenance. We apologise for any inconvenience caused and will post another update ASAP.
Posted Nov 14, 2024 - 08:33 GMT
This incident affected: General Services (EKM Mail).