EKM Mail Slow loading issues
Incident Report for EKM
Resolved
This issue was resolved at 10:30pm yesterday. We apologise for any inconvenience caused.
Posted Nov 07, 2024 - 08:04 GMT
Monitoring
All services appear to be up and running for EKM Mail. We will continue to monitor this before closing.
Thank you for your patience.
Posted Nov 06, 2024 - 12:38 GMT
Investigating
We are currently investigating an issue impacting EKM Mail. This can present as slow loading or login issues for Webmail, POP, and IMAP connections.
Posted Nov 06, 2024 - 12:11 GMT
This incident affected: General Services (EKM Mail).