EKM Mail - Webmail Performance
Incident Report for EKM
Resolved
Our mail provider advised that this issue was resolved at 11:15pm yesterday. We apologise for any inconvenience caused.
Posted Nov 06, 2024 - 08:08 GMT
Update
This issue is now impacting IMAP/POP connections as well if you are are using a mail client such as Outlook or Mail
Posted Nov 05, 2024 - 17:25 GMT
Update
Our team is still looking into the cause, and we'll continue to update you on our progress.
Posted Nov 05, 2024 - 16:50 GMT
Investigating
We are investigating an issue impacting the webmail. This can present as slow loading or login issues.

We will provide an update once we have additional information.
Posted Nov 05, 2024 - 15:17 GMT
This incident affected: General Services (EKM Mail).