Problem accessing Order details on the Orders section

Incident Report for EKM

Resolved

This incident should now be resolved.
Posted Mar 26, 2025 - 09:23 GMT

Investigating

We are currently experiencing an issue with orders not loading correctly on some shops. Our technical team is aware of this and is working diligently to resolve the problem as quickly as possible.

We understand this may cause inconvenience, and we sincerely apologise for any frustration it may cause. We appreciate your patience and understanding while we work to get everything back to normal.

We will provide updates as soon as we have more information.
Posted Mar 25, 2025 - 14:14 GMT
This incident affected: Shop Services (Your Account).