EKM Email Marketing Issues - Investigating

Incident Report for EKM

Resolved

This incident has been resolved
Posted Mar 27, 2025 - 14:02 GMT

Investigating

We are currently investigating an issue which is preventing users from logging in and managing campaigns.
Posted Mar 27, 2025 - 13:58 GMT
This incident affected: General Services (EKM Email Marketing).