Webmail Issue

Incident Report for EKM

Resolved

This issue has now been resolved. We apologise for any inconvenience caused.
Posted Oct 15, 2025 - 14:53 BST

Investigating

Our mail provider is currently investigating an issue where some users are unable to log into their email accounts.

We are sorry for any inconvenience caused and will provide an update once we have additional information.
Posted Oct 15, 2025 - 14:28 BST
This incident affected: General Services (EKM Mail).