EKM Mail - Intermittent Issues
Incident Report for EKM
Resolved
Thank you for your patience. The team has fixed the issues and tests have been done, all services are functional and working as expected now.
Posted Nov 15, 2024 - 09:21 GMT
Investigating
We have received reports of some users having intermittent issues accessing webmail, sending and receiving. We are investigating this. Apologies for any inconvenience that this may cause.
Posted Nov 14, 2024 - 15:34 GMT
This incident affected: General Services (EKM Mail).